Build against libgnutls >= 2.8

VMime 0.9.0 autoconf build process uses the libgnutls-config script to search for GNU TLS (by using AM_PATH_LIBGNUTLS). This script is deprecated and not shipped in gnutls 2.8.0 and later; pkg-config should now be used. Andreas Metzler provided a patch for fixing this.

6 thoughts on “Build against libgnutls >= 2.8

  1. Hi,

    I want apply patch but i known’t do it.

    i am try :

    patch configure fixgnutlsdetect.diff

    It give me this error :
    patching file configure
    Hunk #1 FAILED at 1621.
    1 out of 1 hunk FAILED — saving rejects to file configure.rej

    Thank you !

  2. This doesn’t actually fix the problem. The file attached to the SF comment only changes a line in SConstruct (not even sure what that is). The file that needs to be changed is m4/libgnutls.

  3. I tried the patch and it goes a little further. Still looking for libgnutils:

    *** Could not run libgnutls test program, checking why…

    *** The test program failed to compile or link. See the file config.log for the

    *** exact error that occured. This usually means LIBGNUTLS was incorrectly installed

    *** or that you have moved LIBGNUTLS since it was installed. In the latter case, you

    *** may want to edit the libgnutls-config script: /usr/local/bin/libgnutls-config

    I tried using a pre 2.8 version but there is an issue where gnutils –version returns 2.10.0